Error: "The operation has timed out"

Issue

While attempting to sync Autotask and MS Exchange, you receive the error: "The operation has timed out."

Cause

Time out errors are failures on one of many attempts to synchronize. Timeouts can have multiple causes, including the burden on your Exchange server or a large number of items in the deleted folder of the user being synchronized.

Resolution

To reduce the number of time out errors, you can increase the amount of time between synchronization requests. Adjust the Requested Synchronization every* setting in the Autotask menu > Admin > Extensions & Integrations > Microsoft Extensions > MS Exchange. The minimum amount of time allowed is 10 minutes. You can increase the amount of time between sync cycles without negatively impacting the integration in any way.

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To see if the integration is working, check to ensure all information for the user has synced as expected.