QuickBooks Online Error: "The item is missing in QuickBooks Online"

Issue

When transferring invoices with QuickBooks Online, you receive the error, "Error creating the QuickBooks invoice for Autotask invoice ID XXX and account 'XXX'. Reason: The item 'XXX' is missing in QuickBooks Online. The invoice number for Autotask invoice id XXX and account 'XXX', was set to 'ERROR' in Autotask."

Cause

The item you are trying to transfer does not exist in QuickBooks Online, or there is a category with the same name as the item on the invoice.

Resolution

Make sure the item exists in QuickBooks Online

For an invoice to transfer from Autotask, the billing codes on the items on the invoice must exist in QuickBooks Online. For example, if the error reads "The item 'Onsite Labor' is missing in QuickBooks Online," the billing code called "Onsite Labor" in Autotask does not exist in QuickBooks Online.

To resolve this error:

  • Create the item manually in QuickBooks Online.
  • Ensure the item spelling and formatting matches exactly in Autotask and QuickBooks Online.
  • Make sure your Settings for Autotask invoices to QuickBooks Online app are configured to create the item in QuickBooks Online. If the item exists on the invoice but not in QuickBooks Online, this step is the recommended option.
  • Check for a category in QuickBooks Online with the same name as the item on the invoice. You cannot use categories for items in QuickBooks Online to transfer invoices. To check your product categories in QuickBooks Online, navigate to Settings > Lists > All lists > product categories.
  • Check to make sure that the account type selected is of type, "Revenue". With the account type set to "Asset", it may cause an error.