Error Transferring Expense Report to QuickBooks Online: "No QuickBooks customer was found"
Issue
When attempting to transfer an expense report from Autotask to QuickBooks Online, you see an error similar to the following: "Error processing Expense Report '201805' (id=129) to Quickbooks Online. Details: No QuickBooks customer was found for Autotask account "Microsoft - Entertainment," and there was an error creating a corresponding Customer in QuickBooks. eason: Duplicate Name Exists Error The name supplied already exists. Another customer, vendor or employee is already using this name. Please use a different name."
Cause
- The customer or vendor does not exist, and the user does not have sufficient permissions to create a new customer. Users must have an admin security level in QuickBooks Online to create new customers.
- The customer or vendor exists, but the name is only set for the Display Name, not the actual Organization Name of the customer or vendor in QuickBooks Online.
- The record exists in an incorrect location. For example, a customer name is listed under vendor rather than customer. Vendors, customers, and employee names cannot be the same in QuickBooks. This rule comes from QuickBooks and you cannot bypass it.