QuickBooks Online: Error:"400 Invalid Reference ID: Categories cannot be used in transactions"

Issue

When attempting to sync an invoice to QuickBooks Online, you receive the error, "Error creating the QuickBooks invoice for Autotask invoice ID XXX and account XXX. Reason: There was an error. 400 Invalid Reference ID: Categories cannot be used in transactions. The invoice number for Autotask Invoice ID XXX and account XXX was set to 'ERROR' in Autotask."

Cause

This error typically occurs when an item on the invoice is assigned a category in QuickBooks Online or if the billing item in Autotask matches an existing category in QuickBooks Online.

Resolution

  • The matching billing item in QuickBooks Online cannot be assigned a category.
  • The billing item in Autotask cannot have the same name as a category in QuickBooks Online

If the Billing Item in QuickBooks is assigned a category

Edit the item from within QuickBooks Online:

  1. Navigate to Sales > Products and Services and search for the item.

  2. Edit the item and set the Category to none.
    service1.png

If the name of the Billing Item in Autotask matches the name of a Category in QuickBooks Online

  1. Edit the name of the item in Autotask so that it does not match the name of the category in QuickBooks Online.

  2. Edit the name of the Category in QuickBooks Online so that it does not match the name of the item in Autotask.

  3. Remove all Categories from QuickBooks Online. This step is optional but recommended.

  4. To edit categories in QuickBooks Online, go to Sales > Products and Services > More> Manage Categories.
    service2.png